There are different reasons for email delivery failure from exchange online to on-premises exchange server. Error 550 5.1.10 is one of them.
Problem:
An Office 365 user is unable to send email messages to on-premises Exchange users in an Exchange hybrid deployment.
Cause:
This problem occurs if the user was created in Office 365. In this scenario, the on-premises Exchange environment has no object to reference for the user. Therefore, all queries for that SMTP address fail.
Solution:
To resolve this problem, create a remote mailbox in the on-premises environment and then wait for or force directory synchronization to occur. To do this, follow these steps:
-
Create an on-premises object for the cloud mailbox by using the New-RemoteMailbox cmdlet in the Exchange Management Shell.
Note: This object must have the same name, alias, and user principal name (UPN) as the cloud mailbox.
-
Set the ExchangeGuid property on the new on-premises object that you created in step 1 to match the cloud mailbox. To do this, follow these steps:
A. Connect to Exchange Online by using a remote PowerShell.
B. Use the Get-Mailbox cmdlet to retrieve the value of the
ExchangeGuid
property of the cloud mailbox.For example, run the following command:
Get-Mailbox <MailboxName>| FL ExchangeGuid
D. Use the
Set-RemoteMailbox
cmdlet to set the value of theExchangeGuid
property on the on-premises object to the value that you retrieved in step 2B.For example, run the following command:
Set-RemoteMailbox <MailboxName> -ExchangeGuid <GUID>
-
Wait for directory synchronization to occur. Or, force directory synchronization.
4. Make sure that the Office 365 user object is displayed as Synced with Active Directory.
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