If you want us to run automated checks for the settings mentioned below, select the back button <-- at the top of this page, and then enter the email address of the user who has problems with retention policies.
Issue: Newly created or updated retention policies in the Exchange Admin Center are not applying to mailboxes or items are not moved to the archive mailbox or deleted.
Root Causes:
This may be because the Managed Folder Assistant has not processed the user's mailbox. The Managed Folder Assistant tries to process every mailbox in your cloud-based organization once every seven days. If you change a retention tag or apply a different retention policy to a mailbox, you can wait until the Managed Folder Assist processes the mailbox, or you can run the Start-ManagedFolderAssistant cmdlet to start the Managed Folder Assistant to process a specific mailbox. Running this cmdlet is useful for testing or troubleshooting a retention policy or retention tag settings. For more information, visit Run the Managed Folder Assistant.
Solution:
Run the following command to start the Managed Folder Assistant for a specific mailbox:
Start-ManagedFolderAssistant -Identity <name of the mailbox>
This may also be occur if RetentionHold has been enabled on the mailbox. If the mailbox has been placed on a RetentionHold, the retention policy on the mailbox will not be processed during that time. For more informaton on the RetentionHold setting see: Mailbox Retention Hold.
Solution:
Check the status of the RetentionHold setting on the specific mailbox in EXO powershell:
Get-Mailbox -Identity <name of the mailbox> |fl *retentionHold*
Run the following command to disable RetentionHold on a specific mailbox:
Set-Mailbox -Identity <name of the mailbox> -RetentionHoldEnabled $false
Now, re-run the Managed folder Assistant:
Start-ManagedFolderAssistant -Identity <name of the mailbox>
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